• Willkommen zur 3D-Druck-Community, einer nichtkommerziellen,
  • werbefreien und privaten Plattform rund um das Thema 3D-Drucken
  • vorrangig im deutschsprachigen Raum. Von User für User.
Hallo, Gast! Anmelden Registrieren


Themabewertung:
  • 1 Bewertung(en) - 1 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Funktionierende Marlin Firmware
#11
Du hast noch eine Sache übersehen wenn ich so lese, daß Du einen CTC auf Ramps und 12V umbaust.

Der CTC ist komplett auf 24V ausgelegt. Wenn DU den mit 12V betreiben willst ist das sicherlich möglich, aber bei den kleinen Schrittmotoren wirst Du mit Leistungseinbußen rechnen müssen und das Heizbett funktioniert nicht mit 12V.

Wenn Du so etwas noch nie gemacht hast, dann hast DU DIr was vorgenommen.
Ich kann Dir wie Chris daher nur empfehlen, bevor Du weiter machst, sehr ausführlich einlesen.
Für den Fall daß mein Drucker nicht so wie ich will steht immer ein großer Hammer als Drohung daneben.... Devil
3D-Druck läßt sich ungefähr so gut erklären wie die Eiweißverlagerung des Maikäfers in der Rechtskurve.... Angel
 
Reply to top
#12
Bau lieber das ramps auf 24V um, da hast du weniger Ärger. Dazu findest du einen thread hier im Elektronik-Teil des Forums.

den Temperaturfühler am Hotend gegen einen NTC tauschen ist ja doch kein großes problem.

Schau dir mal die configuration.h an.
Die richtige Arduino-Version hast du?
 
Reply to top
#13
Danke erst einmal für die Hilfe!

Ich dachte nicht, dass es doch so komplex wird, in den ganzen Anleitungen schein es immer recht einfach nach dem Baukastenprinzip zu funktionieren. (30 min einrichten, aufspielen, fertig!)
Das mit dem Umbau auf 24V habe ich auch schon gelesen.

Aber damit wären jetzt auch schon einmal viele Fragen von mir beantwortet!

ich werde mich dann noch einmal tiefer in die Materie einlesen müssen!
 
Reply to top
#14
(10.12.2016, 19:09)JuWiNo schrieb: Ich dachte nicht, dass es doch so komplex wird, in den ganzen Anleitungen schein es immer recht einfach nach dem Baukastenprinzip zu funktionieren. (30 min einrichten, aufspielen, fertig!)

Wenn Du deinen Drucker aus dem FF kennst und die ganzen Parameter für Elektronik und Einstellungen auswendig weißt, ist das in einer halben Stunde erledigt. Wenn Du aber nicht mal den Unterschied zwischen einem K-Typ Sensor und einem NTC-Widerstand kennst, dann musst Du jedes bisschen erst nachlesen, lernen, verstehen und brauchst Wochen. Hinterher kannst Du deinen Drucker aber mit verbundenen Augen zerlegen und wieder zusammensetzen... Wink
Gruß
Chris                    

Leuten, welche die ganze Hand nehmen, wenn man ihnen den kleinen Finger gibt,
sollte man nicht die Stirn bieten...


Meine Drucker:
MKC 4.1 mit Beta-Teilen vom MK2 auf X und Y, MKS Gen 1.4 + TMC2100 (X+Y) + DRV8825, Marlin RC7
MKC MK2, RADDS 1.5 + RAPS 128 + TMC2100 (E) , Repetier 0.92.9
3DDC-Core (beta), MKS Gen 1.4 + TMC2100 (X+Y) + DRV8825, Marlin RC7
...und ein druckerloses MKS SBase 1.3 mit nutzlosem TFT32, das auf Einsatz wartet...


 
Reply to top
#15
(10.12.2016, 20:30)ChrisB schrieb:
(10.12.2016, 19:09)JuWiNo schrieb: Ich dachte nicht, dass es doch so komplex wird, in den ganzen Anleitungen schein es immer recht einfach nach dem Baukastenprinzip zu funktionieren. (30 min einrichten, aufspielen, fertig!)

Wenn Du deinen Drucker aus dem FF kennst und die ganzen Parameter für Elektronik und Einstellungen auswendig weißt, ist das in einer halben Stunde erledigt. Wenn Du aber nicht mal den Unterschied zwischen einem K-Typ Sensor und einem NTC-Widerstand  kennst, dann musst Du jedes bisschen erst nachlesen, lernen, verstehen und brauchst Wochen. Hinterher kannst Du deinen Drucker aber mit verbundenen Augen zerlegen und wieder zusammensetzen... Wink

Hallo zusammen, 

Ich wollte einmal ein kleines Update geben:
also ich habe mich jetzt ein wenig weiter eingearbeitet und viele Sachen funktionieren schon:
Die Temperatur wird richtig angezeigt und die eingestellte Temperatur wird auch gehalten.
Wenn die min_extrudeTemp erreicht ist funktioniert auch der Extruder-Motor richtig.
Die Home-Funktion der Z-Achse funktioniert gut zusammen mit den optischen Endstopps, so dass erst der Endstopp angefahren und er dann noch einmal langsam den genauen Punkt sucht.

zu dem Problemen, die ich noch habe:
Meine X und Y-Achse gehen noch immer nicht (Auch Steuerung über optische Sensoren, so wie die Z-Achse angeschlossen. Die Motoren weisen auch kein Haltemoment auf.
Ich kann die Z-Acshe nur auf Home fahren lassen und nicht mehr so ansteuern, dass sie z.B. 10mm verfährt.

hat jemand eine Idee, was die Fehler verursachen könnte?
Ich habe einmal meine Mechanical Settings angehängt.

Grüße

JuWiNo


Angehängte Dateien
.txt   Mechanical Settings.txt (Größe: 3,51 KB / Downloads: 8)
 
Reply to top
#16
Sind denn die Endstops korrekt eingetellt, sodass sie von der Software als "nicht ausgelöst" angesehen werden? Laut deiner Liste sind die alle gleich "invertiert", wobei mechanische und optische gegensätzlich funktioieren und somit nicht gleich sein können.
Gruß
Chris                    

Leuten, welche die ganze Hand nehmen, wenn man ihnen den kleinen Finger gibt,
sollte man nicht die Stirn bieten...


Meine Drucker:
MKC 4.1 mit Beta-Teilen vom MK2 auf X und Y, MKS Gen 1.4 + TMC2100 (X+Y) + DRV8825, Marlin RC7
MKC MK2, RADDS 1.5 + RAPS 128 + TMC2100 (E) , Repetier 0.92.9
3DDC-Core (beta), MKS Gen 1.4 + TMC2100 (X+Y) + DRV8825, Marlin RC7
...und ein druckerloses MKS SBase 1.3 mit nutzlosem TFT32, das auf Einsatz wartet...


 
Reply to top
#17
Hallo,

ich habe es noch einmal alles durchprobiert mit verscheiden Kombinationen mit und ohne invertierte Endstopps, invertierte Motoren etc.

Wenn ich das Board anschließen Leuchten alle 3 LEDs der Endstopps (alle 3 sind optisch)

Der X-Motor hat zwar ein Haltemoment und summt ein wenig. Die Y-Achse kann ich frei drehen.
Die Pololus habe ich auch einmal durchgetauscht (Spannung nachgemessen ist bei 0,42V)
Motoren habe ich auch durchgetauscht.
Ich habe jetzt noch einmal Zeile für Zeile mit dem Download von diesem Thread verglichen:
http://www.3d-druck-community.de/thread-1988-page-3.html
eigentlich ist alles identisch.
Wenn ich auf Honig gehen und dann manuell die Endstopps für X und Y aktiviere fängt danach auch die Z-Achse an und fahrt automatisch auf 0

SO langsam bin ich mit meinem Latein am Ende, weswegen sich die X und Y Achse nicht bewegen sollen...

Also falls ihr noch Ideen habt...

Grüße

Julian
 
Reply to top
#18
Hallo Julian,

wenn Du nicht so weit weg wärst, würde ich sagen, ...komm mal mit dem Drucker vorbei, aber so, sieh Dich mal nach jemanden mit Ahnung in Deiner Nähe um. Es kann sein, daß man das Problem nur live am Drucker lösen kann.

Gruß Edwin
Für den Fall daß mein Drucker nicht so wie ich will steht immer ein großer Hammer als Drohung daneben.... Devil
3D-Druck läßt sich ungefähr so gut erklären wie die Eiweißverlagerung des Maikäfers in der Rechtskurve.... Angel
 
Reply to top
#19
Also bisher habe ich noch nichts eingebaut.
Ich habe mir als einem Alu-Profil eine kleine Halterung gebastelt, an der die 4 Motoren mit den 3 Endstopps und dem Heizelement befestig sind.
Die Endstopps betätige ich dann halt über einen Schraubenzieher oder Stahlmaß.
Was mich auch ein wenig wundert ist, dass die Schrittmotoren der X und Y Achse anders verhalten, obwohl sie im Code genau die gleichen werte haben (Haltestrom bei der X-Achse)

Ich wollte es erst einmal im uneingebauten Zustand zum laufen bringen, bevor ich mit den Aufwand mache alles einzubauen und dann läuft nichts.
Inzwischen vermute ich auch irgendwie, dass etwas an dem Ramps Board oder dem Arduino kaputt ist.. Angry


Ich habe mal ein Bild von der Verkabelung angehängt.
den Extruder habe ich abgestöpsel für einen besseren Überblick.


Angehängte Dateien Bild(er)
   

.txt   Mechanical Setting_Julian.txt (Größe: 3,27 KB / Downloads: 8)
 
Reply to top
#20
Soeben hat der Postbote geklingelt und ein neues Ramps Board vorbei gebracht.
Da ich bisher alle ausprobiert hatte, vermutete ich, dass das Bord defekt war.
Und es stimmt.
Jetzt laufen die Motoren für die X Y und Z-achse ganz normal!

aber trotzdem danke für eure Hilfe!
Jetzt weiss ich aj an wen ich mich bei neuen Problemen wen den kann!

Danke!
 
Reply to top
  


Möglicherweise verwandte Themen...
Thread Verfasser Replies Views Last Post
  Links zur Firmware Edwin 4 1.320 18.01.2017, 14:21
Last Post: lordwimsey
  CL-260 Marin Firmware mspider 0 232 30.12.2016, 16:33
Last Post: mspider
  Einstellung der Z-Achse in Marlin Firmware Bobbel 14 2.284 08.12.2016, 23:36
Last Post: kayioa
  Wie bastele ich mir eine Marlin Firmware Bobbel 5 798 13.09.2016, 06:36
Last Post: ChrisB
  Firmware update janosch2908 5 829 13.07.2016, 19:35
Last Post: paradroid



Browsing: 1 Gast/Gäste